Possible WA reports service degradation
Incident Report for Kaleyra Cloud
Resolved
This incident has been resolved.
Posted Mar 18, 2022 - 07:18 UTC
Investigating
Observing issue with Whatsapp service where the reports are in queued status.

Working on the same, will keep you posted on the same.
Posted Mar 04, 2022 - 14:14 UTC